Unplanned outage - Cheltenham, VIC 3192

Minor incident Broadband Victoria CNPK - Cheltenham
28-May-2025 08:01 AEST · 1 hour, 33 minutes

Updates

Resolved

Dear Customer,

We are happy to let you know that the power outage caused by a tripped circuit breaker in your Exchange has been resolved as of 9:32 AM AEST on May 28, 2025. The Internet should now be fully restored to all affected households and businesses.

28-May-2025 · 09:31 AEST
Investigating

RedTrain Networks is currently addressing an unplanned network outage impacting services for customers
Incident: Unplanned Network Outage
Start Time: May 28, 2025, 08:01 AEST
Status: Ongoing Service Disruption
Affected Area: Cheltenham, VIC 3192
Estimated Resolution: To Be Determined (TBD)
RedTrain Networks is actively responding to an unplanned network outage impacting services in the specified area. Our technical team is en route to the site to investigate and resolve the issue. We will provide updates as soon as they become available. Thank you for your patience.

28-May-2025 · 08:55 AEST

← Back